One of My Spells stopped working

Hello there, I've never had this issue before so I'm not too sure how to explain it...Yesterday my Judgment Cast for my Paladin was working fine; today when I logged on the tab is grey, as if it were an unusable item on my action bar. I tried resetting my class, switching from my alt class specialization then back again, I've tried exiting the game then re-logging on, oh, and dragging the spell from the talent list back down to the action-bar does not help. I'm out of ideas and a little irritated at this sudden problem.
Make sure one of your seals is active. Judgement requires an active seal to be useable.
Judgement requires a seal to be active before you can use it. Check your seal bar and make sure one is turned on. :)
switching from my alt class specialization then back again

Whenever you swap specs, your seal goes inactive (so you won't be able to use judgement, it will look greyed out), so any time you change your spec, you'll have to click on whichever seal you'd like to use.
You are now officially a paladin. Welcome to the club.

I STILL derp this, usually during arenas!
Been there...I feel much better after reading its happened to others lol
Swapping glyphs/talents does the same thing. Very annoying.

Join the Conversation

Return to Forum