Celestial tank challenge bugged?

Bug Report
For the quest "Celestial Blessings", the tank challenge doesn't appear to be working as intended.

The projectiles the elementals (Molten Brimstone) shoot out are traveling 5 yards then instantly landing on wrathion. Aren't they supposed to travel along the ground to Wrathion / be blockable?
I can confirm that the same issue is happening to me. Safeguard doesn't seem to stop them from hitting him either. I should note that when I first tried the quest on Friday (7/19), the bolts were acting normally. What ever caused this issue happened within the last 48 hours or so.
Just had the same thing happen to me. No way to defend him from the projectiles. They moved a small distance and then he immediately ate them.
I'm doing the healer version and have a similar problem same phase. I can see the elementals but never see their bolts. Just periodic bursts of fire on Wrathion (W). Furthermore, (I'm hypothesizing this is a bug as well) after that phase W just continues to cower in the middle. This lasts until DW fixates on him. So that means while healing all the damage done by the bolts I couldn't stop, I have agro from DW and he's casting the fire blobs on me... not workable. Need a fix or a better tank (W sux). I tried disabling my addons, reloading,... nothing fixes this and not real happy with my repair bill or general frustration after working my butt off to get to this point.
I'm seeing the same thing. I've watched some youtube videos and the graphics I'm seeing are very different than what are on the youtube video. Mine barely spawn and then immediately hit him, whereas in the youtube video they fly for a bit giving you a chance to move to intercept them.

I wonder if he is showing up with a huge hit box or something weird like that.
I'm having the problem. It was working fine yesterday and now you have
no chance of saving him with the bug.
Having this issue as well. I managed to somehow prevent him from dieing once. But before I could finish off Deathwing he just bugged out, didn't move, and stood in the giant meteor AoE like a champ.

Defiantly possible for tanks, but like, it takes quite a few attempts because you have 0-1 second to react to each bolt, meanwhile its coming at at a rate of 1 per second or so.
Take that back, you have no time to react, I have been trying lots of different stuff.

I thought initially that if you cross his hit box that it might bug it? Not the problem.

Then I tried moving absurdly quick not even caring about mitigation, damage, whatever (granted the damage if fairly miniscule since I can negate it with second wind quite easily). But the game doesn't register you as in the path because of server lag. It still thinks you're on the other side or on top of him, and not in between.

For those of you who are stubborn like myself and still want to get the cape in spite of the bug, I have come up with 2 ways to finish the challenge until they fix it. With all of these strats the more health wrathion has the more leeway you have with the damage.

1. Stand in front of one of them and just hope that he casts it way more than the others.

2. Jump around wildly and hope you intercept some (has been working out mildly well for me some attempts and doesn't do anything on others).

Good luck, hope they fix it soon.
yep i tried the tank challenge on a different toon. it is doing it. much worse then the dps challenge.
I had the same issue as well. Went and did the DPS challenge instead.
Same thing is happening to me, wonder why Blizz hasnt said anything or fixed it yet.
Appears the fixed it or the server reset took care of it. I was able to block the projectiles today and finish the quest.
This is still broken or bugged.. perhaps it is something that once bugged will stay that way until reset?
I too have been having this issue. Several attempts yielded only the same result. Wrathion dieing to missiles strikes. I have been lucky enough to survive the first barrage by blocking a couple and ensuring he absorbs little damage throughout the fight, but the end result is the same once I get to the next missile fight. I understand that this is supposed to be a challenging quest, but the challenge ends when futility takes over. Having only a miniscule amount of time to react is not what I've seen on you tube videos others have posted. please advise us all on this one Blizzard!

Note also how many hours many of us have spent on this quest line to get to this point.

Join the Conversation

Return to Forum