World of Warcraft Not Working on Windows 8.

Technical Support
I have got a windows 8 computer witch i have been DYING to play WoW on it ever when i first got WoW. So i downloaded the Starter Edition Launcher Thing and it just said Checking for updates.... for four hours. I just rage quit and downloaded it on my parents windows 7 computer and worked like a charm. But then i tried to put in on my Windows 8 PC and i move over all the files over with a flash drive and it still says, Checking for updates....

Dose anyone out there know what to do to help or is having the same problem as me.
Please help.

It sounds like something is preventing the launcher. There are lots of things that can cause this.

Disabling or temporarily uninstalling firewall and anti-virus programs (Norton, McAfee, etc) can permit the launcher to run successfully. Of course, do not remove security software if you can't reinstall it, and always restore disabled security after patching.

Proxy settings on your system can also block access. Make sure to disable proxy settings from the control panel:
    Pull up your Control Panel and select Internet Options.
    Click on the Connections tab.
    Click the button called "LAN Settings"
    Uncheck all of the options on that screen.
    Then try again.

Try pulling up Internet Explorer to make sure your system is not set to offline mode.

Make sure you have the latest version of flashplayer.

The launcher requires secondary logon service to be enabled in order for it to run properly.

If the issue persists, we can try resetting the launcher files completely. Follow the steps here to do that.

Rate me!
Do you know how to disable the firewall on Norton i cant do it via control panel to wont let me click on the turn on or off button. So i tried to go into norton but it is very complex can you help?
wait it is stuck on Initializing... any help? EDIT: How do u change the hard drive were it goes?

(i have 809 GB left out of 912 some)

The installation destination can be changed when you first install the game. Afterwards you can just drag the game folders to another location and then adjust your shortcuts manually. The game will run fine from a new location.

For Norton, you may want to use their removal tool to temporarily remove it. Norton will often continue to block things when disabled.

It sounds like the launcher files have downloaded and you're now going through the installation. Is it downloading data? Are you getting closer to the 912GB?

Rate me!
Ok it worked and Thank you :) i Rated you with everything positive :)
Glad to hear it, Coriz. Thanks for the update and review!

Rate me!
It has occurred that when i finally worked it came up with the same problem an I did all the steps and when i went to Norton I found out that the internet connection was a bar thing and gray and had a lock on it for all Blizzard related stuff and the firewall was set to allow. Any hints?
You using Norton 360? you can try adding wow files to the exception list these are all the files you need to add. Here is a nice video I found earlier I think its the same no mater which Norton security product you own


Blizzard Launcher.exe

warcraft folder
World of Warcraft Launcher.exe

Ya Norton 360
It did not work and it still says Checking for updates... thing
Try this. Need to follow the instructions for all the wow files above. This will allow access with the fire wall

Norton 360 All-in-One Security
1.Open Norton 360.
2.Click Task & Settings in the main menu.
3.Click Advanced Settings.
4.Click Firewall Protection Settings.
5.Click Firewall Program Rules tab.
6.Select Logic "world of warcraft files" in the list.
7.Select Allow (not Auto or Custom) in the Access column beside The wow files.
8.Click Apply.
I have recently move my WoW to a Windows 8 PC i had some help getting it started and changing the config and i worked then i reset my PC for the night and when i started it up i just said CHECKING FOR UPDATES!!!!!!!!!!! Please help :)


Did you try allowing the files through the Norton Firewall? What were your results?

Rate me!

Norton will often continue to block data even when disabled. You may want to temporarily remove it and then test the launcher.

Rate me!
im not going to disable NORTON. but it says it is through the firewall and i checked the second logon and unchecked the LAN settings I am confused

It would just be temporary while we're troubleshooting. I wouldn't recommend doing any web browsing or running suspicious applications while we're troubleshooting anyway. The step will help isolate the issue though.

Once we're done troubleshooting we'll restore the system to it's normal state.

Rate me!
NOOOO your all wrong!!! I figured it out and now is installing. You have to enable secondary administration and put it on automatic and disable anti virus for a little bit. wow this was frustrating but that is what worked I have win 8.1
This has gotten very frustrating! WoW worked fine under windows 7 but is totally unplayable under windows 8 for me. I have re installed WoW 3 times now along with Win 8 3 times, followed all the suggestions i could find in these forums, MS forums and what i could find in Google searches. best i could narrow it down to... has something to do with an update to windows. WoW works fine till a batch of updates occur (preformed automatically by windows 8) and then i get to play for about 5 min before the video lag starts. I can still see the chat scrolling by for a short bit but everybody is running in place and i'm doing no damage. then after 2 to 5 min of this, I'm disconnected. Grrr

Join the Conversation

Return to Forum