How To: Disable water elemental sound UPDATED

Mage
The recent patch broke the previous fix as it removed the ability to use custom wav files AND it will default back to the MPQ if it cannot play the file. The fix has been updated as layed out below:


If you are like me then you are being driven nuts by the constant glug glug glug sound!!!!
Well with very little digging I have found the sound file responsible for my torment, so without anymore babbling here is how you kill that annoying sound.
[NOTE THAT ALL FOLDERS AND FILES ARE CASE SENSITIVE!]

Step 1: File Structure

Go to your World of Warcraft/Data folder, check for a folder named "Sound" if no folder exists make one.
Now go inside the Sound folder you created (or if one already existed ) now you are going to make another folder inside Sound named "Creature" (If for any reason one already existed leave it) go into your Creature folder.
Now the last folder you will make will be "WaterElemental" Your folder structure should now look like this: World of Warcraft/Data/Sound/Creature/WaterElemental


Step 2: Creating the File

This part is extremely simple, go to https://docs.google.com/open?id=0Bx7BY-89MQo_YjhoNTFGWkNSdldoWWdiSnhGQkl2UQ
Download the file WaterElementalLoop.ogg and move it into your WaterElemental folder, enjoy!


If you don't trust the download link, record a period of silence, convert it to ogg format, and save it as WaterElementalLoop.ogg. Then move the file into the above directory.
And with more vuvuzela!!

Removed as the host file is gone and it no longer plays wav files anyways.
Rofl, vuvuzela ftw xD
Or you can just go into your sound options and untick pet sounds :)
Or you can just go into your sound options and untick pet sounds :)


That's actually not true. Pet sounds has nothing to do with the ambient sound that the WE makes.
Or you can just go into your sound options and untick pet sounds :)


That's actually not true. Pet sounds has nothing to do with the ambient sound that the WE makes.


Oh I see, then Blizzard should really make it do that.
Vuvuzela hahaha, upvote :)
Thank you for this :D I hate that sound.
Favorited, Now i wont feel like Im adventuring in an aquarium. Well...Vash'jir...whatever.
I'm going to try this tip, thanks. That bubbling water sound is driving me insane and nothing else would make it stop. I hatehateHATE that blurble noise. >_<

Really wish Blizz would've attached the elemental's sound to the pet sound toggle. Why they didn't is beyond me.
Thanks for this! Now if I could get a way to keep the WE from getting in my way whenever I want to look at something. I end up dismissing him all the time because he makes me crazy getting in my way.
please tell me that this "solution" doesn't play the vuvuzela noise instead?
Oh my.. Thank you!! That sound is terrible.
12/22/2010 5:11 AMPosted by Toquen
please tell me that this "solution" doesn't play the vuvuzela noise instead?


I would suggest reading the post in its entirety.
. . .

Thank you.
thank you so very much!!!!!!
Thanks.. this was driving me crazy.
I'll add my thanks to everyone else here... I made my first Mage a few days ago after years of melee classes, and this noise was driving me crazy. A helpful guy on my server directed me here after I mentioned it in city chat.

EDIT: And I'll add that when saving the Notepad file in Windows 7, you need to change the "Save as Type" dropdown from "Text Documents (*.txt)" to "All Files." I left it alone the first time, and it saved the file as WaterElementalLoop.wav.txt, which didn't work, of course.
Well I could NOT get it to turn off by using the info above! But I did found something else and it is so much easier to do to turn that ANNOYING water sound off.

Addon by Curse

http://wow.curse.com/downloads/wow-addons/details/waterelementalmage-sound-remover.aspx

Hopes this helps anyone that needs it.
Any way to make it randomly sing like that plants vs zombies pet? Maybe the same tune just modulated down like 2 octaves? With some extraneous gurgling sounds?

Do want.

Join the Conversation

Return to Forum