Can't loot rares on Timeless Isle

Bug Report
Prev 1 2 3 4 9 Next
Happens to me all the time with Arch. I was in a Rep group for doing the Ordon Sanc, We killed Arch FOUR TIMES. I could loot it only ONCE. I normally wouldn't care, but he dropped the Elixir of Ancient knowledge, I know this because Out of the five of us, three people got it. The only people that didn't? Were myself and a hunter. THAT I did put in a ticket for. Because frankly, this has been going on since the release of the patch, and THAT is the one bloody item I want so I can finish leveling an alt without wanting to pound my face with a hammer doing the same quests/dungeons I've done on thirty other characters again.
^yep, I was only having the looting issue with Arch. Could only loot him once, and also this was at the three-wind area if that helps at all.
Gettin' real tired of this. Been happening to me all day today, but just on Huolon!
I'm hoping they can do something via ticket . I had trouble with 11 rares today either no loot at all, or no coins at all. (I killed many today)
i have had this happen on archiereus and golganarr
I've killed archiereus somewhere around 20-30 times in the last few days. I have been able to loot him a total of 2 times. I'm not even going to bother with him any more. Makes me sad every time. :(
This ^
so much this^

I see people saying arch is up, i dont even go anymore, its just a repair bill for a boss i cant loot.

also, not running any mods. tried relogged, redeleting wtf/interface, repairing.

its a loot query DB issue on your end blizzard.
Such a common problem after that last batch of rolling restarts - not sure why it hasn't been addressed. I generally only see this when I kill Huolon though. I do get coins and tokens auto-looted to me - as with the ship and Evermaw, but I never actually get the "baggable" loot from the spawn. Armour tokens and whatnot that he drops almost constantly.

Kills me because every time - literally now every time - I kill Huolon I can't loot him. Just makes me not even want to bother because even if the mount drops for me, how will I ever know?
I have had the same issue with Huolon, Archiereus of Flame and just now with a random pack of Gulp Frog/Crag Stalker/Windfeather Nestkeeper x2 (which aren't even rares). I kept killing random mobs in the area to be able to loot and nothing worked. I couldn't even mine a nearby ore. This needs to be fixed!!!
I hope a blue responds to this im going to sticky this thread!
same problem, killed garnia, showed I could loot him and whenver i clicked to loot my character half bent over and nothing, kept trying to loot for like 5 mins before it vanished and my loot was lost.
I too am getting sick of this.

Nothing like having cinderfall or the pirate ship kill you 4 times, then not be able to loot.

Just lost loot on Huolon to this bug. Able to see the bag icon, but no amount of clicking will get the loot window up.
Same issue here, very annoying.
Same issue, please fix it.
This is certainly getting annoying, being how widespread this is, it's even more irritating that we haven't gotten a response from Blizzard about this.

I don't care about the loot I've missed, but I do care about it being allowed to continue to happen.

Very frustrating.
So far i've had this happen on 4 rares today ( 6 yesterday of a 16 hour of gameplay)

Edit: The following NPC's i've experienced this bug is on Evermaw, Dead Ship, Huluon, Cinderfall, Archflame
Same issues, very frustrating as it has happened about 10 times today

Join the Conversation

Return to Forum