Launching Diablo IV Gives Error Message About Requiring Windows 10

Updated: 9 months ago
Article ID: 319985
Product:

Common Problems

I receive the error "You need at least windows 10 (version 1909)." in Diablo IV.

Diablo IV requires at least windows 10. If you are already running Windows 10 or higher make sure to update your operating system.

If the issue persists try to reinstall the Battle.net App.