Este artículo no está disponible en español.
A continuación te mostramos la versión en inglés.

Companion App Error - "Subscription Required"

Actualizado: hace 1 año
ID del artículo: 177959
Productos relevantes:

Problemas comunes:

  • I have a subscription but my companion app says I need one when I try to log in
  • I can't log in to the Legion companion app, error "Subscription required"

There are three reasons you may be getting the "Subscription required" error in the WoW Companion App:

  • The App was updated with the release of Battle for Azeroth to be used for Battle for Azeroth content. You will receive this error if you have not yet purchased the Battle for Azeroth upgrade for your World of Warcraft account.
  • You will receive this error if you do not currently have game time on your account
  • You have game time and have upgraded the game but it's not being recognized by the app
If you have game time and have fully upgraded the app, try the following troubleshooting steps:
  • Reset your password to refresh your account cache
  • Delete the app from your phone and reinstall it